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1. Introduction 

 
 
The program AdvancedReport performs automatic conversion of the data files and the 
event files of the Yokogawa recorder from the DX, DXP, FX, DXAdvanced and MV1000 
family. 
By the user’s own configurations, it is possible to select the export file between the formats 
ASCII [csv] and Microsoft Excel freely. Additionally, it is possible to use an Excel-template.  
If the Excel template is not used, it is not necessary to install Excel on the computer. 
 
A further advantage is in the user-defined designation of the export file. Batch data, 
starting times and further characteristics for the automatic file designation can be used. 
 
For an effective conversion it is possible to activate the times of the function at different 
intervals. 
 
A condition for these functions is the presence of the data files, display data files and/or 
display event files in a folder on the Windows PC. Using the ftp client function of the 
Yokogawa recorders, it is possible to store the files on the PC. For further information 
please read operating instructions of the recorder. 
 

For updates and changes about the program, please read the info file stored in the 
installation folder or contact your Yokogawa sales team. 
 
 

 

 
Note: 
Please read this manual to find solutions! 

 

 
 
 
 

2. Revision 

 

Date Version Reason 

12.12.2014 1 English version 

08.2016 2 Update Service Documentation 

09/2018 3 Update installation procedure 

05/2019 4 Update Microsoft Excel  

11/2019 5 Update  

12/2019 6 Update Excel Addin 

01/2020 7 Update Excel Macro / Add Application 

12/2020 8 Update DCOM Settings 
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3. System Requirements 

 
3.1 Hardware 

 
For the documentation of the test, a paperless Data recorder is required.  The Data 
recorders listed below are supported by the Add in:   
 
 

Recorder File extension Data type 

GX20 / GP20 / GM10 
GX10 / GP10 
www.smartdac.com 
 
[with /AS1 Pharma Option] 

.GDS 

.GEV 
 

.GSE 

.GSD 
[/AS1 Pharma Option]  

Display Data 
Event Data 
 
Display Data 
Event Data 
[with /AS1 Pharma Option] 

DX1000 / DX1000N / DX2000  
[ DXAdvanced ] 
www.DAQStation.com 
 

.DAD 

.DAE 
Display Data 
Event Data 

DX1000 / DX2000    
[with /AS1 Pharma Option] 

 

.DSD 

.DSE 
Display Data 
Event Data 

DX100 / DX200 
 
 

.DDS 

.DEV 
Display Data 
Event Data 

FX1000  
 
 

.DAD 

.DAE 
Display Data 
Event Data 

MV1000 / MV2000  
[ MVAdvanced ] 
 

.DAD 

.DAE 
Display Data 
Event Data 

FX100  
 
 

.DDS 

.DEV 
Display Data 
Event Data 

DX100P / DX200P 
Pharma-Ausführung 
 

.DBD 

.DBE 
Display Data 
Event Data 

MW100 / MX100 
 

.MXD 
 

Data 
 

DL850 
 

.WDF Data files 

 
For the analysis using a PC, the following minimum hardware requirements must be met.   
 
• Hard disk capacity:  30 MB 
• Memory:  4GB 
 

http://www.smartdac.com/
http://www.daqstation.com/
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3.2 Software 

The program AdvancedReport Version 2 is Windows based and requires therefore a 
Windows Operating System. 
 

3.3 Prerequirement 
 

- Windows .Net Framework 4 Full installation (is checked by setup) 
o http://www.microsoft.com/en-us/download/details.aspx?id=17718 

 
 

3.4 Operating System 
 
The program has been tested on the following platforms1: 

- Windows 7 [32bit] 
- Windows 7 [64bit] 
- Windows 8 [64bit] 
- Windows 10 [32bit] 
- Windows 10 [64bit] 
- Windows Server 2008 
- Windows Server 2012 
- Windows Server 2012R2 
- Windows Server 2016 

 
 

3.5 Additional Software 
 
For using an Excel Template check the following requirements: 
 

- Export only   → Microsoft Excel is NOT required.  
- Chart / Trend function  → Microsoft Excel is NOT required.  
- Print function   → Microsoft Excel is required.  
- VBA function   → Microsoft Excel is required.  

 
For using the Template Creator, the following Microsoft Excel Version is necessary: 

 
- Microsoft Excel 2010 [32Bit]  
- Microsoft Excel 2013 [32Bit] 
- Microsoft Excel 2016 [32Bit] 
- Microsoft Excel 365 [32Bit] 

 
For creating the Report, there is also an older or newer installed version possible. 

 
1 Microsoft Windows and Excel are a registered trademarks or trademarks of Microsoft Corporation in the United States 

and/or other countries 

http://www.microsoft.com/en-us/download/details.aspx?id=17718
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4. Download 

 
Load the latest version of our solution from the following web Page: 
 
https://www.AdvancedTools.de 
 
 

4.1 Internet Explorer Message 

 
If the Internet Explorer Function enables “SmartScreen Filter” you get sometime the 
following Message Window.  
 

 
“SmartScreen Filter” Click Actions 

 

 
Click Don’t run this program otherwise it has been download again. 

 

https://www.advancedtools.de/
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5. Installation preparation 

 
5.1 Necesarry data 

 
For the installation of the program the file SetupAdvancedReportV2_xxx.exe, and a license 
number are required. 
The license number will be given at the delivery of the package. Keep this information 
carefully! 
 
The recorded data files should be available at the computer where the AdvancedReport 
program is installed. The best solution is to activate the FTP server function which is 
available in Windows XP and 2000. All Yokogawa recorders have an automatic FTP 
function which sent the data files to the FTP server, the data files then will be stored in a 
specified directory. This directory will be accessed by AdvancedReport program to perform 
the data conversion.  
The procedure to activate the FTP server in Windows XP and an automatic FTP 
configuration example is explained in chapter 8. 
 

5.2 Trial version 
 
For trial leave the field for the serial no empty.  
All functions are available in the trial function as well. During the data conversion all fifth 
data points will be replaced by the word DEMO. 
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6. Installation Procedure Diagram 

 
For Installation please follow the Installation Diagram. Each step will be described at the 
following chapter.                                              
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7. Installation .Net Framwork 

 
7.1 Windows Server 2016 

 
 
For the installation of Windows .Net Framework it is required to use the Windows 
installation CD or an Internet connection. 
 

- Windows .Net Framework 2 Full installation 
- Windows .Net Framework 4 Full installation 

 
 

 
Start Server Manger  
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Add a role 

 
 

 
Follow the assistant 
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Role based installation 

 

 
Use the active partition 
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Check no extras 

 

 
.Net Framework 3.5 Features 
➔ .Net Framework 3.5 Features (include .Net 2.0 and 3.0) 
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If there is no Internet connection available, select the path to the Windows installation CD. 

 

 
Use the path with the folder „/SxS“ 
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Installation starts 

 

 
Installation successfully 
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7.2 Windows 10 
Windows .Net installation 
 

 
Control Panel → Programs and Features  

 
 

 
„Turn Windows features on or off“  
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.Net Framework 3.5 Features 
➔ .Net Framework 3.5 Features (include .Net 2.0 and 3.0) 

 
 

 
If there is an Internet connection it will be start automatically. 
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Installation succefully 

 
 

7.3 Windows 7  
 
For installation on Windows 7 it is necessary to download the .Net framework from the 
Microsoft Webpage. 
 
 

- Windows .Net Framework 4 Full installation 
o http://www.microsoft.com/en-us/download/details.aspx?id=17718 

 

http://www.microsoft.com/en-us/download/details.aspx?id=17718
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8. Installation AdvancedReport 

 
Execute the program SetupAdvancedReport.exe. 
 

 
Install the software with administrative rights 

 
 
Then  a window to select the language will appear. 
Select “ English” and confirm it with the “OK” button.. 
 

 
Language selection  

 
Confirm the welcome window with “Next”. 
 



 

 
AdvancedReportV2  /   Installation   

 

 
 

 
20/74  

 

 
Welcome display 

 
 

 
Informations 
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License Agreement 
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 Read the information carefully and confirm it with the button “Next”. 
 

 
Information 

 
Select the destination location folder for the AdvancedReport program and conform it to 
the “Next” button. 
  

 
Selection of destination folder 

 
Then enter the key code and name.  
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If the key code is correct then the installation of the program will be activated with the 
button “Next”. 

 
Registration 

 
Select option 

 
Select the installation option and confirm the selection with the button “Next”. Use the 
full installation for the best result. 
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Startmenu name 

 
Select the additional task shortcuts activation and confirm it with the “Next” button. 
 

 
Addition task shortcuts 
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In the following abstract the listing of the selections made is displayed and can be 
confirmed by the button “Install”. 
 
If checkbox “Install as Service” checked, the following Form will be shown, otherwise 
not. 

 
Installation as Service 
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Abstract 

 
The installation of the program starts. With the “Abort” button it is possible to stop the 
installation. 
If the Software already installed, it must be Deinstall before installing a new Version. 
All the settings are not deinstall. 
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Deinstall previous version 

 

 
UNistall routine works automatically 

 
 
 

 
Installation 
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Message, if the Service couldn’t install, please check the Server installation Chapter! 

 
 
After installation the button “Finish” must be pressed. 
 

 
Finish Installation 

 
The program can now be started from Start → Programs → AdvancedReport → 
AdvancedReport. 
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9. Windows FTP server installation 

9.1 Windows XP 
 

• Open the Windows XP control panel via START > SETTINGS > CONTROL PANEL 
 

• Select ADD AND REMOVE PROGRAMS 
 

              
 

• Select on the left side of the screen the “Add/Remove Windows Components” button 
 

              
• Select “Internet Information Services (IIS)” and select the DETAILS button. Ensure that the options 

as shown in the following picture are selected. 
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• After confirming your selections by pressing the OK button select NEXT in the previous screen. Now 
the server software will be installed. For this you do need the official Windows XP CD. 

 

• After completing the installation open the control panel START > SETTINGS > CONTROL PANEL 
 

• Select “Administrative Tools” 
 

 
• Double click “Internet Information Services” to see the IIS status. After selecting the folder “FTP 

Sites” you will see in the right side of the screen the state of the “Default FTP Site” that should 
“Running”. 
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• This default FTP site accepts requests from anybody (mentioned as “anonymous) without any 
authentication. This is not good for security and the FTP server should be dedicated for the DX2000. 
Therefor some additional settings should be made. 

 

• Select in the right side of the window the “Default FTP Site” and right click the mouse. Now select 
PROPERTIES and the properties window will open. 

 

• In the SECURITY ACCOUNTS tab ensure that the “Allow anonymous connections” is NOT selected. 
Confirm your action by selecting YES. 

 

             
 
 
 
 
 
 

• Now select the HOME DIRECTORY tab. Select here the options “Write” and make sure that “Read” 
and “Log visits” are already selected. The directory listing style should be “MS-DOS”. 
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• Confirm your settings by pressing OK and close the ISS status window. 
 

• In the “Administrative Tools” window now double click “Computer Management”. 
 

 
 
 

• In this new window double click on “Local Users and Groups” to open the folders Users and Groups. 
Now select the folder User. In the right window a list of all registered users is shown. 
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• We do need to register DAQSTATION as a new user. For this press in the toolbar ACTION > NEW 
USER. Now a new window will open and fill in the following data; 
 
User name  : CENTUM 
Full name   : CENTUM 
Description  :  
Password  : <Your Password> 
Confirm password : <Your Password> 
 
After this remove the check for “User must change password at next login” and do check “Password 
never expires”. 

 

              
 

• Now conform your settings by selecting CREATE and after that close the window by pushing the 
CLOSE button. 
The new user DX-01 will now show up in the list. 

 

• Close all open windows and start windows explorer. In the explorer select the folder 
C:\Inetpub\ftproot. Create in this folder a new folder with the name dx-ftp. 
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• Now select the new folder and by right clicking it open the properties of the folder. After this select 
the SECURITY tab. 

 

              
 
 
 
 
 
 
 
 
 

• First remove all users from the shown list. Then click the ADD button. Ensure that in the “From this 
location” line the name of your computer is mentioned. 
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• Click the ADVANCED button. 
 

              
 

• Click the FIND NOW button. After this a list of users is shown in the lower part of the screen. Here 
select the new user and select OK. In the previous windows also select OK. 

 

• In the dx-ftp properties window select the ADVANCED button. 
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• In the PERMISSIONS tab of this window both optional selections must NOT be selected. And 
confirm your setting by selecting the OK button twice. 

 

• The FTP server software is now installed and ready for use. 
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9.2 Windows 7 FTP server installation 
 

• Open the Windows 7 control panel via START > SETTINGS > CONTROL PANEL 
 

• Select PROGRAMS 
 

             

 
 

• Select on the left side of the screen the “Add/Remove Windows Components” button 
 

 
Or 

 
              

• Select “Internet Information Services (IIS)” and select the DETAILS button. Ensure that the options 
as shown in the following picture are selected. 
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• After confirming your selections by pressing the OK button select NEXT in the previous screen. Now 
the server software will be installed. For this you do need sometimes the official Windows 7 CD. 

 
 
 

• After completing the installation open the control panel START > SETTINGS > CONTROL PANEL 

• Open the Control Panel on your system. And click on Administrative Tools. In case you are unable 
to locate Adminstrative Tools in the control panel, you may need to switch to 'View all control panel 

items' from the "View by" menu at the top right in your control panel window. 

 

http://files.digitizor.com/wp-content/uploads/2009/06/ftp-iis-windows7-settings-1.JPG
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• In the Administrative Tools windows, locate "Internet Information Services Manager" and click on 
it. You can now see a new window with lot of settings / options in it categorised separately under 
FTP and IIS. 

 
 

• Double click “Internet Information Services” to see the IIS status. After selecting the folder “FTP 
Sites” you will see in the right side of the screen the state of the “Default FTP Site” that should 
“Running”. 

     

 
 

• To create a FTP site please start the FTP wizard. 

 

http://files.digitizor.com/wp-content/uploads/2009/06/ftp-iis-windows7-settings-2.JPG
http://files.digitizor.com/wp-content/uploads/2009/06/ftp-iis-windows7-settings-3.JPG
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• Confirm your settings by pressing Finish and close the ISS status window. 
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• In the “Administrative Tools” window now double click “Computer Management”. 
 

 
 
 

• In this new window double click on “Local Users and Groups” to open the folders Users and Groups. 
Now select the folder User. In the right window a list of all registered users is shown. 
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• We do need to register DAQSTATION as a new user. For this press in the toolbar ACTION > NEW 
USER. Now a new window will open and fill in the following data; 
 
 
User name  : CENTUM 
Full name   : CENTUM 
Description  :  
Password  : <Your Password> 
Confirm password : <Your Password> 
 
After this remove the check for “User must change password at next login” and do check “Password 
never expires”. 

 

              
 

• Now conform your settings by selecting CREATE and after that close the window by pushing the 
CLOSE button. 
The new user CENTUM will now show up in the list. 
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• Close all open windows and start windows explorer. In the explorer select the folder 
C:\USDA\FTPServer. Create in this folder a new folder with the name dx-ftp. 

 

              
 

• Now select the new folder and by right clicking it open the properties of the folder. After this select 
the SECURITY tab. 

 

              
 
 
 
 
 
 
 
 
 

• First remove all users from the shown list. Then click the ADD button. Ensure that in the “From this 
location” line the name of your computer is mentioned. 
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• Click the ADVANCED button. 
 

              
 

• Click the FIND NOW button. After this a list of users is shown in the lower part of the screen. Here 
select the new user and select OK. In the previous windows also select OK. 

 

• In the dx-ftp properties window select the ADVANCED button. 
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• In the PERMISSIONS tab of this window both optional selections must NOT be selected. And 
confirm your setting by selecting the OK button twice. 

 

• The FTP server software is now installed and ready for use. 
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9.3 Test FTP Function / Testing the FTP Transfer 
 
You can test whether a test file can be transferred from the DX to an FTP server. 
◊ Press FUNC and select FTPtest 
Items to check before performing this test 
• Connect the Ethernet cable correctly. For the connection procedure, see section 1.3. 
• Check that the Ethernet interface settings are correct. For the procedure, see section 
 
Checking the results of the FTP test 
• When an FTP test is executed, a test file named FTP_TEST.TXT is transferred to the 
directory indicated by the initial path at the FTP destination specified in this section. 
• The result of the FTP test can be confirmed by displaying the FTP log 
 
Press FUNC to display the FUNC key menu at the bottom of the screen. Press the 
Next soft key to switch the menu. Press the desired soft key. 
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10. Windows Firewall 
 

10.1 Windows 7 
 

• Open the Windows control panel via START > SETTINGS > CONTROL PANEL 
 

• Select System and Security 
 

             

 
 

• Select on the left side of the screen the “Allow a program through Windows firewall” button 
 

 
Or 
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•  
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11. Microsoft Excel Settings 
 
 

11.1 Enable macros in Office files 
 
A macro is a series of commands that you can use to automate a repeated task, and 
can be run when you have to perform the task. This article has information about the 
risks involved when you work with macros, and you can learn about how to enable or 
disable macros in the Trust Center. 
 

11.1.1 Enable macros when the Message Bar appears 
 
When you open a file that has macros, the yellow message bar appears with a shield 
icon and the Enable Content button. If you know the macro, or macros, are from a 
reliable source, use the following instructions: 

• On the Message Bar, click Enable Content. 
The file opens and is a trusted document. 
 

The following image is an example of the Message Bar when macros are in the file. 

 
 

11.2 Enable macros in the Backstage view 
Another method to enable macros in a file is via the Microsoft Office Backstage view, 
the view that appears after you click the File tab, when the yellow Message Bar 
appears. 

1. Click the File tab. 
2. In the Security Warning area, click Enable Content. 
3. Under Enable All Content, click Always enable this document's active content. 

The file becomes a trusted document. 
 

The following image is an example of the Enable Content options. 

 
11.3 Change macro settings in the Trust Center 

 

Macro settings are located in the Trust Center. However, if you work in an organization, 
the system administrator might have changed the default settings to prevent anyone 
from changing settings. 
Important: When you change your macro settings in the Trust Center, they are changed 
only for the Office program that you are currently using. The macro settings are not 
changed for all your Office programs. 

1. Click the File tab. 
2. Click Options. 
3. Click Trust Center, and then click Trust Center Settings. 

https://support.office.com/en-us/article/trusted-documents-cf872bd8-47ec-4c02-baa5-1fdba1a11b53
https://support.office.com/en-us/article/trusted-documents-cf872bd8-47ec-4c02-baa5-1fdba1a11b53
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Add the Application Path to the trusted location 
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11.4 Create Report with Service Function  
 

To convert the Data files within the Excel Template you have to create a Folder under 
Windows 7 and Windows 8. 
 
IMPORTANT: Create the following Folder! 
 

64-bit %WinDir%\SysWOW64\config\systemprofile\Desktop 
 
And 
 
%WinDir%\System32\config\systemprofile\Desktop  

32-bit %WinDir%\System32\config\systemprofile\Desktop 

 
 

 

 
ATTESION IMPOTANT: 
It is only possible to create this folder as a user with administrative Rights! 
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11.5 Software Template Creator Excel Addin 
 
 

11.5.1 (OLD Version) Check out “COM Add-Ins” dialog in Excel 

Now open Excel and see if your add-in loads successfully. If not, open Excel Options 
dialog (File->Options) and navigate to Add-Ins tab.  
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12. Run Program as NT- Service 

 
It is possible to start the program as a service. With this it is not necessary to login on 
the computer. It starts automatically with Windows. 
 
 

 

 
Note: 
Also, the FTP Server has to run as a Service! 

 

 
 
 
 

12.1 Installation 
 
Change to the Settings register. The Button „Install“ add the service 
„AdvancedReportSvc“ into the control panel. The Button „Start“ activate the Service. 
The service start as „System“ User in Automatic Mode.  
By changing the settings, it will be activate with a new folder scan. 
 

 
Install Service in AdvancedReport 

 

 
Install the Service as User  
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The messages are sent to the Windows event logger (Control Panel → Administrative 
Tools → Events). 
 

 

Windows Services 

 
 
 

12.2 Installation with printer support and using Excel template 
 
 
If you want to print the report on paper, please follow the next steps: 
 

12.3 create a new lokal user: 
control panel → Adminstrative tools → Computer Management  
Local user and groups → user 

 

 
Computer Management 
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Create a new user 

 
You have to set a password! 
 

  
User settings 

With Version 2.7 und newer the service will be restart after an Error Counter of 10. 
For this function it is important to start the service as an user with administrative 
rights. 
 

 

 
ATTESION IMPOTANT: 
It is important to start the service as a user with administrative rights.  
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12.4 Use Excel Template and Excel VBS Macro within the service 

 
To convert the Data files within the Excel Template you must create a Folder 
under Windows 7 and Newer. 
 
IMPORTANT: Create the following Folder! 
 

64-bit %WinDir%\SysWOW64\config\systemprofile\Desktop 
 
And 
 
%WinDir%\System32\config\systemprofile\Desktop  

32-bit %WinDir%\System32\config\systemprofile\Desktop 

 

 

 
ATTESION IMPOTANT: 
It is only possible to create this folder as a user with administrative Rights! 

 
12.4.1 Enable macros in the Backstage view and start Excel within the Service User!!! 

 

Start MS Excel to change this setting within the Service Running User!! 
 

 

 
ATTESION IMPOTANT: 
Start MS Excel to change this setting within the Service Running User!! 

 
Another method to enable macros in a file is via the Microsoft Office Backstage view, 
the view that appears after you click the File tab, when the yellow Message Bar 
appears. 

4. Click the File tab. 
5. In the Security Warning area, click Enable Content. 
6. Under Enable All Content, click Always enable this document's active content. 

The file becomes a trusted document. 
 

The following image is an example of the Enable Content options. 

 
 
 
 
 

https://support.office.com/en-us/article/trusted-documents-cf872bd8-47ec-4c02-baa5-1fdba1a11b53
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12.4.2 Change macro settings in the Trust Center  

 

Macro settings are located in the Trust Center. However, if you work in an organization, 
the system administrator might have changed the default settings to prevent anyone 
from changing settings.  
Important: When you change your macro settings in the Trust Center, they are changed 
only for the Office program that you are currently using. The macro settings are not 
changed for all your Office programs. 

4. Click the File tab. 
5. Click Options. 
6. Click Trust Center, and then click Trust Center Settings. 
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Add the Application Path to the trusted location 

 
 
 
 

12.4.3 Change the settings for the service: 
 

Control Panel → Adminstrative tools → Services 
 

 
Service run with local system account 

 
 
 

  
Stop the service 
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Change from System-account to local user account 
In this example we use the local user “CENTUM” 

 
 

 
Service run with local user account 
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Restart the service 

 
 
 

12.5 Setting DCOM Permissions 
To run Jet reports in a scheduled task you must have permissions to open and activate 
the Excel application.  These permissions can be set using the DCOM Configuration 
utility. 
To run the DCOM Configuration utility have your system administrator click the 
Windows orb and type DCOMCNFG to open the Component Services console. 
 
 

 

 
ATTESION IMPOTANT: 
On 64-bit systems running a 32-bit version of MS Excel, 
type DCOMCNFG -32 to open the 32-bit version of the Component 
Services console* 
 

  
• Go to Console Root->Component Services->Computers->My Computer-

>DCOM Config->Microsoft Excel Application, right-click it, and 
select Properties. 

• Click on the Security tab, 
• Select the Customize option in the Launch and Activation Permissions section 

and click the Edit… button. 
• Click Add... and add the user that needs to run the Jet scheduled task. 
• Select the newly added user and allow the Local Launch , Remote 

Launch , Local Activation , and Remote Activation options (click OK) 
• Select the Customize option in the Access Permissions section and click 

the Edit... button. 
• Click Add... and add the user that needs to run the Jet scheduled task. 
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• Select the newly added user and allow Local Access and Remote 
Access (click OK) 

 

 
Component Service 

 

 
Location → Check “Run application on the computer where the data is located” 
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Security → Launch and Activaten Permisson → Add Administrors 
Allow all settings for : 
All Local Service / Administrators / INTERACTIVE / Users / NETWORK SERVICE / 
<Service User Name> 

 

 
Security → Access Permisson → Add Administrors and Allow all settings 
Allow all settings for : 
All Local Service / Administrators / INTERACTIVE / Users / NETWORK SERVICE / 
<Service User Name> 
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Security → Configuration Permisson → Add Administrors and Allow all settings 
Allow all settings for : 
All Local Service / Administrators / INTERACTIVE / Users / NETWORK SERVICE / 
<Service User Name> 

 
 
 
*NOTE: on 64-bit systems running 32-Excel, if Microsoft Excel Application does not 
appear in the DCOMCNFG list, it may be necessary to run the 32-bit version of 
the Microsoft Management Console [mmc -32] in order to add the 'Component Services' 
snap-in.  Contact your system administrator for further assistance. 
 

12.6 De-Installation Service 
 
Change to the Settings register. The Button „Stop“ stopped the service. After stopping 
the service it is possible to deinstall the servie by using the button „Un-Install“.  

 
Stopp and Deinstall 
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13. PDF Printer 

 

13.1 Windows 10 
 

For Windows 10 there is a PDF Printer preinstalled. This printer is not recommend to use as default 

printer in this Software. It will be  

 

 

13.2 PDFCreator Configuration 
 
 

• Open the printer configuration in All Programs > PDFCreator >  PDFCreator  

• After Printer > Options the settings windows appears. 

              
 

• Select the Options part Auto-save. 

• In the tab Auto save select “Use Auto save” and “Use this directory for auto-save”. Add  the folder 
name “C:\USDA\PDF_Files” for saving the Files 
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• All other settings can be default. 
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13.3 Add printer to the local user 
 
Login as new local user. 
 
Add a printer to the user account. Ask your Administrator for more details. 
 

 
Printers and Faxes 
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14. De-installation Program 

 
The de-installation can be done by the uninstall-routine of Windows. To be found under 
Start → Settings → Control panel → Software. 
 

15. Additional Options 

 
The program AdvancedReport does not need an entry in the registry of Windows. All 
settings are stored into the file AdvancedReport.ini. Only the function „Start with 
Windows“ will be defined an entry into the registry when this is activated. 
The Dll-files do not need a registration.  
It is possible to move the program or to start as batch program. All the files should then 
be in the same folder. 
 

16. More Solutions 

 
Also available are the following software products: 

 

- AdvancedSQL 

o The program AdvancedSQL inserts automatically data from the 
Yokogawa paperless recorders into any database. 

 

- TUSReport - Addin for AdvancedReportV2 
o The program TUSReport serves automatic converting of the data files 

and the event files of the Yokogawa recorder from the DX, DXP, FX 
and DXAdvanced family into the NADCAP Report format. 
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17. Appendix 

 
17.1 Solution 1: DCOM Settings for Microsoft Excel Interop Function 

 

In some cases of Windows Security settings, it is not possible to start the Excel Interop 
Function. 
In this case you will get the following Error Message at the Windows Event log. 
  

 
Error line: 980 

System.Runtime.InteropServices.COMException (0x80080005): Retrieving the COM class factory for component with 

CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80080005 Server execution failed 

(Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)). 

Windows Event Log 

 
To solve the settings, please start the following software component.  
IMPORTANT:  

1. Start the software with this Command! 
2. Start with “Run As Administrator” 

 

 
 
Start → Run → MMC comexp.msc /32 
 

Start Component Services  (Use the /32 to check the 32-Bit Office setting!!!) 
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Find the entry “Microsoft Excel Application”. 
 

 
→Component Services → Computers → My Computer → DCOM Config 

➔ Select Microsoft Excel Application 
➔ right click - Settings - Security Tab 

 

 

1.         2.       

2. Launch and Activation Permissen  /  Access Permission 
a. Add LOCAL SERVICE → ALLOW ALL 
b. Add INTERACTIVE → ALLOW ALL 
c. Add Adminstrators → ALLOW ALL 
d. Add USERS → ALLOW ALL 

e. Add NETWORK SERVICE → ALLOW ALL 

f. Add <Service User Name> → ALLOW ALL 
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Now go to "Identity" and select "The interactive user". 
Save every Window mit “Apply” and “OK” 
 
 
Save every Window mit “Apply” and “OK”!!!!! 
 

 

 

 
IMPORTANT:  
If the problem not solved, change the “Identity” to “The Launching user”. 

 

 
Now go to "Identity" and select "The launching user". 
Save every Window mit “Apply” and “OK” 
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17.2 Solution 2: System.Runtime.InteropServices.COMException (0x80080005) 

The tell here is the error:  
"Error Failed to create Engine..Exception=System.Runtime.InteropServices.COMException 
(0x80080005)..."  

This error indicates you're running into Windows default limitation of 10 COM objects, 
commonly known as the Desktop Memory Heap. 
 
The memory heap is a Windows settings that effects the number of concurrent 
processes of the same kind. If you enable a high number of reload engines, and start 
seeing windows errors related to Windows running out of DeskTop Heap Size. This will 
be visible in the Windows System Event log, with errors saying "DeskTop Heap 
exhausted". If so, you will need to adjust Windows DeskTop Heap Size to allow for a 
higher server load. 
 

 

IMPORTANT: Windows registry changes are made at your own risk and are 
not supported by us. Please make a backup of the Windows registry before 
applying changes to enable rollback if the settings change fails 
or introduces Windows instability. 

Desktop Memory Heap size is control in the following Windows registry key: 
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session 
Manager\SubSystems\Windows 

Change the desktop heap setting by setting the SharedSection value to 1024,20480,2048. 
After change the registry key should look something like the following (all on one line): 

%SystemRoot%\system32\csrss.exe ObjectDirectory=\Windows 
SharedSection=1024,20480,2048 Windows=On SubSystemType=Windows 
ServerDll=basesrv,1 ServerDll=winsrv:UserServerDllInitialization,3 
ServerDll=winsrv:ConServerDllInitialization,2 ProfileControl=Off 
MaxRequestThreads=16 
 
Notice that the default value is 1024,3072,512 in x86 or 1024,20480,768 in x64 
environments. 

!!Take care, only change the SharedSection Value!!!  

Microsoft references on Windows heap size: 
http://blogs.msdn.com/ntdebugging/archive/2007/07/05/desktop-heap-part-2.aspx 
http://blogs.msdn.com/ntdebugging/archive/2007/01/04/desktop-heap-overview.aspx 

 

http://blogs.msdn.com/ntdebugging/archive/2007/07/05/desktop-heap-part-2.aspx
http://blogs.msdn.com/ntdebugging/archive/2007/01/04/desktop-heap-overview.aspx

